Twitter detecta vulnerabilidad en aplicación para Android

La red social de micromensajería Twitter advirtió una vulnerabilidad en su aplicación, que afectará a dispositivos equipados con versiones más antiguas del sistema operativo Android.

La falla permitiría que un atacante acceda a datos privados disponibles en Twitter, como mensajes directos, eludiendo los permisos del sistema que protegen el dispositivo.

La compañía indicó que el problema involucra a los usuarios que utilizan las versiones 8 (Oreo) y 9 (Pie) del sistema operativo de Google. Sin embargo, no ha afectado la aplicación para iOS ni a la versión de escritorio.

Según los datos proporcionados por Twitter, el 96 por ciento de sus usuarios contarían con un parche de seguridad que los protege. “No tenemos evidencia de que haya sido explotada por los atacantes”, afirmó.

Como primera medida de seguridad, recomendó a los usuarios mantener la aplicación actualizada a la última versión disponible para Android.

De todos modos, agregó que “como no podemos estar completamente seguros” de que no se produzcan ataques, implementará una medidas para proteger al 4 por ciento de usuarios potencialmente vulnerables:

  • Actualización de Twitter para Android, para garantizar que las aplicaciones externas no puedan acceder a los datos de la aplicación, agregando medidas de seguridad adicionales a las estándar del sistema operativo.
  • Solicitar a cualquier persona que sea potencial víctima que actualice su aplicación de Twitter para Android.
  • Enviar avisos en la aplicación a todas las personas que podrían haber sido víctimas, para informarles si necesitan implementar alguna acción.
  • Identificar cambios en los procesos internos, con el objetivo de mejorar los resguardos contra problemas como el detectado.

Recomendaciones del editor